1

Closed

Problems executing on Vista

description

Vista, VS2005 (SP1), GAX(1.2)
 
Not able to run recipes, get various TypeLoadExceptions for various Actions in Recipes.Common.
 
Indications are dependencies on Vista.
 
We are looking into why this is.
Can anyone provide more information? i.e. fusion log info?
Closed May 19, 2007 at 9:55 PM by jezzsa
Solved until future issues arisen

comments

jannemattila wrote Apr 25, 2007 at 9:34 PM

I'm running Windows Vista, VS 2005 SP1, GAT/GAX (June 2006 CTP OR Feb 2007 CTP) - Installation was OK, but when you add "DSL Toolwindow" it creates following exception:

System.TypeLoadException: Could not load type 'DslEditorPowerToy.Recipes.Converters.RelativeFolderPathConverter' from assembly 'DslEditorPowerToy.Recipes.Common, Version=1.0.0.0, Culture=neutral, PublicKeyToken=4de90bd4dc49828b'. at System.Reflection.Assembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase) at Microsoft.Practices.Common.Services.TypeResolutionService.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) at Microsoft.Practices.Common.Services.AliasResolutionService.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) at Microsoft.Practices.Common.Services.TypeResolutionService.GetType(String typeName, Boolean throwOnError) at Microsoft.Practices.RecipeFramework.GuidancePackage.CreateAndConfigureConverter(Argument argument, ITypeResolutionService resolution, TypeConverter converter) at Microsoft.Practices.RecipeFramework.GuidancePackage.EnsureInitializeMetadataForCurrentRecipe() at Microsoft.Practices.RecipeFramework.GuidancePackage.Execute(String recipe, IAssetReference reference, IDictionary arguments) at Microsoft.Practices.RecipeFramework.GuidancePackage.Execute(IAssetReference reference) at Microsoft.Practices.RecipeFramework.RecipeReference.OnExecute() at Microsoft.Practices.RecipeFramework.AssetReference.Execute() at Microsoft.Practices.RecipeFramework.PackageManagement.PackageManager.OnExecuteRecipe(Object sender, EventArgs e)

wrote May 9, 2007 at 10:25 AM

This could be becuase of how the PowerToy is installed on Vista.
Although recipes, are running after install. Perhaps some file failed install ???
 
Either way, need to fix the installer to work with UAC.

wrote May 9, 2007 at 10:26 AM

Associated with changeset 2217.

wrote May 11, 2007 at 9:01 PM

wrote May 12, 2007 at 8:51 PM

Associated with changeset 2353.

wrote May 19, 2007 at 9:55 PM

wrote Feb 12, 2013 at 7:24 PM

wrote May 15, 2013 at 3:21 AM